Back to overview
Downtime
Everything is down
May 29 at 08:41pm NDT
Affected services
Personal Website
Immich
Jellyfin
Resolved
May 30 at 08:20pm NDT
Networking issues resolved.
Affected services
Personal Website
Immich
Jellyfin
Created
May 29 at 08:41pm NDT
Landlord cut the fibreoptic cable. ISP is sending someone to repair it tomorrow.
Affected services
Personal Website
Immich
Jellyfin